PyPI/django CVE-2016-2512: unknown, EPSS 4.05%
The utils.http.is_safe_url function in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks or possibly conduct cro
Action: Upgrade django to 1.8.10 or later.
pip install django==1.8.10pip install django==1.9.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.8.10 | - |
| 1.9 | 1.9.3 | - |
Fixed versions
| 1.8.10 | 1.9.3 |
Sources
- osv: PYSEC-2016-15
- https://github.com/django/django/commit/c5544d289233f501917e25970c03ed444abbd4f0
- https://www.djangoproject.com/weblog/2016/mar/01/security-releases/
- http://rhn.redhat.com/errata/RHSA-2016-0504.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/83879
- http://www.ubuntu.com/usn/USN-2915-2
- http://www.ubuntu.com/usn/USN-2915-3
- http://www.debian.org/security/2016/dsa-3544
- http://rhn.redhat.com/errata/RHSA-2016-0502.html
- http://rhn.redhat.com/errata/RHSA-2016-0505.html
- http://rhn.redhat.com/errata/RHSA-2016-0506.html
- http://www.ubuntu.com/usn/USN-2915-1
- http://www.securitytracker.com/id/1035152
- https://github.com/advisories/GHSA-pw27-w7w4-9qc7
CVE-2016-2512 · published · modified · JSON