PyPI/django CVE-2016-2513: unknown, EPSS 3.35%
The password hasher in contrib/auth/hashers.py in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to enumerate users via a timing attack involving login requests.
Action: Upgrade django to 1.8.10 or later.
pip install django==1.8.10pip install django==1.9.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.8.10 | - |
| 1.9 | 1.9.3 | - |
Fixed versions
| 1.8.10 | 1.9.3 |
Sources
- osv: PYSEC-2016-16
- https://www.djangoproject.com/weblog/2016/mar/01/security-releases/
- https://github.com/django/django/commit/67b46ba7016da2d259c1ecc7d666d11f5e1cfaab
- http://rhn.redhat.com/errata/RHSA-2016-0504.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/83878
- http://www.ubuntu.com/usn/USN-2915-2
- http://www.ubuntu.com/usn/USN-2915-3
- http://www.debian.org/security/2016/dsa-3544
- http://rhn.redhat.com/errata/RHSA-2016-0502.html
- http://rhn.redhat.com/errata/RHSA-2016-0505.html
- http://rhn.redhat.com/errata/RHSA-2016-0506.html
- http://www.ubuntu.com/usn/USN-2915-1
- http://www.securitytracker.com/id/1035152
- https://github.com/advisories/GHSA-fp6p-5xvw-m74f
CVE-2016-2513 · published · modified · JSON