PyPI/mercurial CVE-2016-3068: unknown, EPSS 5.41%
Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted git ext:: URL when cloning a subrepository.
Action: Upgrade mercurial to 3.7.3 or later.
pip install mercurial==3.7.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.7.3 | - |
Fixed versions
| 3.7.3 |
Sources
- osv: PYSEC-2016-26
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00017.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/181505.html
- https://selenic.com/repo/hg-stable/rev/34d43cb85de8
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.7.3_.282016-3-29.29
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/181542.html
- http://www.debian.org/security/2016/dsa-3542
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00043.html
- http://rhn.redhat.com/errata/RHSA-2016-0706.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/85733
- https://security.gentoo.org/glsa/201612-19
- https://github.com/advisories/GHSA-j7c2-rqm3-c97m
CVE-2016-3068 · published · modified · JSON