PyPI/django CVE-2016-7401: unknown, EPSS 5.70%
The cookie parsing code in Django before 1.8.15 and 1.9.x before 1.9.10, when used on a site with Google Analytics, allows remote attackers to bypass an intended CSRF protection mechanism by setting a
Action: Upgrade django to 1.8.15 or later.
pip install django==1.8.15pip install django==1.9.10Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.8.15 | - |
| 1.9 | 1.9.10 | - |
Fixed versions
| 1.8.15 | 1.9.10 |
Sources
- osv: PYSEC-2016-3
- http://www.securitytracker.com/id/1036899
- https://www.djangoproject.com/weblog/2016/sep/26/security-releases/
- http://www.debian.org/security/2016/dsa-3678
- http://www.securityfocus.com/bid/93182
- http://www.ubuntu.com/usn/USN-3089-1
- http://rhn.redhat.com/errata/RHSA-2016-2043.html
- http://rhn.redhat.com/errata/RHSA-2016-2042.html
- http://rhn.redhat.com/errata/RHSA-2016-2041.html
- http://rhn.redhat.com/errata/RHSA-2016-2040.html
- http://rhn.redhat.com/errata/RHSA-2016-2039.html
- http://rhn.redhat.com/errata/RHSA-2016-2038.html
- https://github.com/advisories/GHSA-crhm-qpjc-cm64
CVE-2016-7401 · published · modified · JSON