PyPI/pillow CVE-2016-9190: unknown, EPSS 1.90%
Pillow before 3.3.2 allows context-dependent attackers to execute arbitrary code by using the "crafted image file" approach, related to an "Insecure Sign Extension" issue affecting the ImagingNew in S
Action: Upgrade pillow to 3.3.2 or later.
pip install pillow==3.3.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.3.2 | - |
Fixed versions
| 3.3.2 |
Sources
- osv: PYSEC-2016-9
- http://pillow.readthedocs.io/en/3.4.x/releasenotes/3.3.2.html
- https://github.com/python-pillow/Pillow/issues/2105
- https://github.com/python-pillow/Pillow/pull/2146/commits/5d8a0be45aad78c5a22c8d099118ee26ef8144af
- http://www.securityfocus.com/bid/94234
- http://www.debian.org/security/2016/dsa-3710
- https://security.gentoo.org/glsa/201612-52
- https://github.com/advisories/GHSA-w4vg-rf63-f3j3
CVE-2016-9190 · published · modified · JSON