PyPI/django CVE-2017-7234: unknown, EPSS 1.85%
A maliciously crafted URL to a Django (1.10 before 1.10.7, 1.9 before 1.9.13, and 1.8 before 1.8.18) site using the ``django.views.static.serve()`` view could redirect to any other domain, aka an open
Action: Upgrade django to 1.8.18 or later.
pip install django==1.10.7pip install django==1.9.13pip install django==1.8.18Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.8 | 1.8.18 | - |
| 1.9 | 1.9.13 | - |
| 1.10 | 1.10.7 | - |
Fixed versions
| 1.10.7 | 1.9.13 | 1.8.18 |
Sources
- osv: PYSEC-2017-10
- https://www.djangoproject.com/weblog/2017/apr/04/security-releases/
- http://www.securityfocus.com/bid/97401
- http://www.securitytracker.com/id/1038177
- http://www.debian.org/security/2017/dsa-3835
- https://github.com/advisories/GHSA-h4hv-m4h4-mhwg
CVE-2017-7234 · published · modified · JSON