tocsin

PyPI/dulwich CVE-2017-16228: unknown, EPSS 3.71%

Dulwich before 0.18.5, when an SSH subprocess is used, allows remote attackers to execute arbitrary commands via an ssh URL with an initial dash character in the hostname, a related issue to CVE-2017-

Action: Upgrade dulwich to 0.18.5 or later.

pip install dulwich==0.18.5

Affected

introducedfixedlast affected
00.18.5-

Fixed versions

0.18.5

Sources

CVE-2017-16228 · published · modified · JSON