tocsin

PyPI/mercurial CVE-2017-1000116: critical 9.8, EPSS 6.54%

Mercurial prior to 4.3 did not adequately sanitize hostnames passed to ssh, leading to possible shell-injection attacks.

Action: Upgrade mercurial to 4.3 or later.

pip install mercurial==4.3

Affected

introducedfixedlast affected
04.3-

Fixed versions

4.3

Sources

CVE-2017-1000116 · published · modified · JSON