PyPI/rope CVE-2014-3539: critical 9.8, EPSS 2.97%
base/oi/doa.py in the Rope library in CPython (aka Python) allows remote attackers to execute arbitrary code by leveraging an unsafe call to pickle.load.
Action: Upgrade rope to 0.11.0 or later.
pip install rope==0.11.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.11.0 | - |
Fixed versions
| 0.11.0 |
Sources
- osv: PYSEC-2018-100
- nvd: CVE-2014-3539
- https://bugzilla.redhat.com/show_bug.cgi?id=1116485
- http://www.openwall.com/lists/oss-security/2015/02/07/1
- https://github.com/advisories/GHSA-r38r-qp28-2m63
CVE-2014-3539 · published · modified · JSON