PyPI/luigi CVE-2018-1000843: unknown, EPSS 0.81%
Luigi version prior to version 2.8.0; after commit 53b52e12745075a8acc016d33945d9d6a7a6aaeb; after GitHub PR spotify/luigi/pull/1870 contains a Cross ite Request Forgery (CSRF) vulnerability in API en
Action: Upgrade luigi to 2.8.0 or later.
pip install luigi==2.8.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.8.0 | - |
Fixed versions
| 2.8.0 |
Sources
- osv: PYSEC-2018-11
- https://groups.google.com/forum/#!topic/luigi-user/ZgfRTpBsVUY
- https://github.com/spotify/luigi/pull/1870
- https://github.com/spotify/luigi/blob/2.7.9/luigi/server.py#L67
- https://github.com/advisories/GHSA-p69g-f978-xxv9
CVE-2018-1000843 · published · modified · JSON