PyPI/keystone CVE-2017-2673: high 7.2, EPSS 2.10%
An authorization-check flaw was discovered in federation configurations of the OpenStack Identity service (keystone). An authenticated federated user could request permissions to a project and uninten
Action: Upgrade keystone to 10.0.2 or later.
pip install keystone==10.0.2pip install keystone==11.0.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 9.0.0 | 10.0.2 | - |
| 11.0.0 | 11.0.1 | - |
Fixed versions
| 10.0.2 | 11.0.1 |
Sources
- osv: PYSEC-2018-152
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2673
- https://bugs.launchpad.net/keystone/+bug/1677723
- http://seclists.org/oss-sec/2017/q2/125
- https://access.redhat.com/errata/RHSA-2017:1597
- https://access.redhat.com/errata/RHSA-2017:1461
- http://www.securityfocus.com/bid/98032
CVE-2017-2673 · published · modified · JSON