PyPI/aiohttp-session CVE-2018-1000814: unknown, EPSS 0.97%
aio-libs aiohttp-session version 2.6.0 and earlier contains a Other/Unknown vulnerability in EncryptedCookieStorage and NaClCookieStorage that can result in Non-expiring sessions / Infinite lifespan.
Action: Upgrade aiohttp-session to 2.7.0 or later.
pip install aiohttp-session==2.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.0 | - |
Fixed versions
| 2.7.0 |
Sources
- osv: PYSEC-2018-35
- https://github.com/aio-libs/aiohttp-session/pull/331
- https://github.com/aio-libs/aiohttp-session/issues/325
- https://github.com/advisories/GHSA-mr4x-c4v9-x729
CVE-2018-1000814 · published · modified · JSON