tocsin

PyPI/ansible CVE-2017-7481: unknown, EPSS 4.78%

Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be

Action: Upgrade ansible to 2.3.1.0 or later.

pip install ansible==2.3.1.0
pip install ansible==2.4.0.0

Affected

introducedfixedlast affected
02.3.1.0-
2.3.2.02.4.0.0-

Fixed versions

2.3.1.02.4.0.0

Sources

CVE-2017-7481 · published · modified · JSON