PyPI/gunicorn CVE-2018-1000164: unknown, EPSS 2.37%
gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attac
Action: Upgrade gunicorn to 19.5.0 or later.
pip install gunicorn==19.5.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 19.5.0 | - |
Fixed versions
| 19.5.0 |
Sources
- osv: PYSEC-2018-55
- https://github.com/benoitc/gunicorn/issues/1227
- https://epadillas.github.io/2018/04/02/http-header-splitting-in-gunicorn-19.4.5
- https://lists.debian.org/debian-lts-announce/2018/04/msg00022.html
- https://www.debian.org/security/2018/dsa-4186
- https://usn.ubuntu.com/4022-1/
- https://github.com/advisories/GHSA-32pc-xphx-q4f6
CVE-2018-1000164 · published · modified · JSON