PyPI/trytond CVE-2014-6633: unknown, EPSS 2.58%
The safe_eval function in trytond in Tryton before 2.4.15, 2.6.x before 2.6.14, 2.8.x before 2.8.11, 3.0.x before 3.0.7, and 3.2.x before 3.2.3 allows remote authenticated users to execute arbitrary c
Action: Upgrade trytond to 2.4.15 or later.
pip install trytond==2.4.15pip install trytond==2.6.14pip install trytond==2.8.11pip install trytond==3.0.7pip install trytond==3.2.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.4.0 | 2.4.15 | - |
| 2.6.0 | 2.6.14 | - |
| 2.8.0 | 2.8.11 | - |
| 3.0.0 | 3.0.7 | - |
| 3.2.0 | 3.2.3 | - |
Fixed versions
| 2.4.15 | 2.6.14 | 2.8.11 | 3.0.7 | 3.2.3 |
Sources
- osv: PYSEC-2018-59
- https://bugs.tryton.org/issue4155
- http://www.tryton.org/posts/security-release-for-issue4155.html
- https://github.com/advisories/GHSA-m9jj-5qvj-5fhx
CVE-2014-6633 · published · modified · JSON