PyPI/oauthenticator CVE-2018-7206: unknown, EPSS 1.77%
An issue was discovered in Project Jupyter JupyterHub OAuthenticator 0.6.x before 0.6.2 and 0.7.x before 0.7.3. When using JupyterHub with GitLab group whitelisting for access control, group membershi
Action: Upgrade oauthenticator to 0.6.2 or later.
pip install oauthenticator==0.6.2pip install oauthenticator==0.7.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.6 | 0.6.2 | - |
| 0.7 | 0.7.3 | - |
Fixed versions
| 0.6.2 | 0.7.3 |
Sources
- osv: PYSEC-2018-68
- https://blog.jupyter.org/security-fix-for-jupyterhub-gitlab-oauthenticator-7b14571d1f76
- https://github.com/jupyterhub/oauthenticator/commit/1845c0e4b1bff3462c91c3108c85205acd3c75a2
- https://github.com/jupyterhub/oauthenticator/blob/8499dc2/CHANGELOG.md#073---2018-02-16
- https://github.com/advisories/GHSA-8x3m-m3x9-54fj
CVE-2018-7206 · published · modified · JSON