PyPI/mercurial CVE-2018-17983: critical 9.1, EPSS 2.01%
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
Action: Upgrade mercurial to 4.7.2 or later.
pip install mercurial==4.7.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.7.2 | - |
Fixed versions
| 4.7.2 |
Sources
- osv: PYSEC-2018-91
- nvd: CVE-2018-17983
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.7.2_.282018-10-01.29
- https://www.mercurial-scm.org/repo/hg/rev/5405cb1a7901
- https://github.com/advisories/GHSA-p575-cf9h-wv42
CVE-2018-17983 · published · modified · JSON