PyPI/numpy CVE-2019-6446: critical 9.8, EPSS 27.27%
** DISPUTED ** An issue was discovered in NumPy 1.16.0 and earlier. It uses the pickle Python module unsafely, which allows remote attackers to execute arbitrary code via a crafted serialized object,
Action: Upgrade numpy to 1.16.1 or later.
pip install numpy==1.16.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.16.1 | - |
Fixed versions
| 1.16.1 |
Sources
- osv: PYSEC-2019-108
- nvd: CVE-2019-6446
- https://github.com/numpy/numpy/issues/12759
- https://bugzilla.suse.com/show_bug.cgi?id=1122208
- http://www.securityfocus.com/bid/106670
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/7ZZAYIQNUUYXGMKHSPEEXS4TRYFOUYE4/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00091.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00092.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00015.html
- https://access.redhat.com/errata/RHSA-2019:3335
- https://access.redhat.com/errata/RHSA-2019:3704
- https://github.com/advisories/GHSA-9fq2-x9r6-wfmf
CVE-2019-6446 · published · modified · JSON