PyPI/python-gnupg CVE-2019-6690: unknown, EPSS 8.62%
python-gnupg 0.4.3 allows context-dependent attackers to trick gnupg to decrypt other ciphertext than intended. To perform the attack, the passphrase to gnupg must be controlled by the adversary and t
Action: Upgrade python-gnupg to 0.4.4 or later.
pip install python-gnupg==0.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.4 | - |
Fixed versions
| 0.4.4 |
Sources
- osv: PYSEC-2019-115
- https://seclists.org/bugtraq/2019/Jan/41
- https://pypi.org/project/python-gnupg/#history
- https://lists.debian.org/debian-lts-announce/2019/02/msg00021.html
- http://www.securityfocus.com/bid/106756
- http://packetstormsecurity.com/files/151341/Python-GnuPG-0.4.3-Improper-Input-Validation.html
- http://lists.opensuse.org/opensuse-security-announce/2019-02/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2019-02/msg00008.html
- https://blog.hackeriet.no/cve-2019-6690-python-gnupg-vulnerability/
- https://usn.ubuntu.com/3964-1/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W6KYZMN2PWXY4ENZVJUVTGFBVYEVY7II/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/X4VFRUG56542LTYK4444TPJBGR57MT25/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3WMV6XNPPL3VB3RQRFFOBCJ3AGWC4K47/
- https://github.com/advisories/GHSA-qh62-ch95-63wh
- https://github.com/advisories/GHSA-2fch-jvg5-crf6
CVE-2019-6690 · published · modified · JSON