PyPI/rediswrapper CVE-2019-17206: unknown, EPSS 3.19%
Uncontrolled deserialization of a pickled object in models.py in Frost Ming rediswrapper (aka Redis Wrapper) before 0.3.0 allows attackers to execute arbitrary scripts.
Action: Upgrade rediswrapper to 0.3.0 or later.
pip install rediswrapper==0.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.3.0 | - |
Fixed versions
| 0.3.0 |
Sources
- osv: PYSEC-2019-116
- https://github.com/frostming/rediswrapper/pull/1
- https://github.com/frostming/rediswrapper/releases/tag/v0.3.0
- https://github.com/frostming/rediswrapper/compare/v0.2.1...v0.3.0
- https://github.com/advisories/GHSA-vrcf-g539-x6h3
CVE-2019-17206 · published · modified · JSON