PyPI/sqlalchemy CVE-2019-7164: unknown, EPSS 3.50%
SQLAlchemy before 1.3.0b3 allows SQL Injection via the order_by parameter. The fix (commit 30307c4) was applied only to the main branch and was never backported to the 1.2.x release line; all 1.2.x ve
Action: Upgrade sqlalchemy to 1.3.0b3 or later.
pip install sqlalchemy==1.3.0b3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.3.0b3 | - |
Fixed versions
| 1.3.0b3 |
Sources
- osv: PYSEC-2019-123
- https://github.com/sqlalchemy/sqlalchemy/issues/4481
- https://lists.debian.org/debian-lts-announce/2019/03/msg00020.html
- https://access.redhat.com/errata/RHSA-2019:0984
- https://access.redhat.com/errata/RHSA-2019:0981
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00087.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00016.html
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://github.com/advisories/GHSA-887w-45rq-vxgf
CVE-2019-7164 · published · modified · JSON