PyPI/sqlalchemy CVE-2019-7548: unknown, EPSS 1.78%
SQLAlchemy 1.2.17 has SQL Injection when the group_by parameter can be controlled.
Action: Upgrade sqlalchemy to 1.2.18 or later.
pip install sqlalchemy==1.2.18Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.2.18 | - |
Fixed versions
| 1.2.18 |
Sources
- osv: PYSEC-2019-124
- https://github.com/no-security/sqlalchemy_test
- https://github.com/sqlalchemy/sqlalchemy/issues/4481#issuecomment-461204518
- https://lists.debian.org/debian-lts-announce/2019/03/msg00020.html
- https://access.redhat.com/errata/RHSA-2019:0984
- https://access.redhat.com/errata/RHSA-2019:0981
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00087.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00016.html
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://github.com/advisories/GHSA-38fc-9xqv-7f7q
CVE-2019-7548 · published · modified · JSON