PyPI/twisted CVE-2019-12855: unknown, EPSS 1.81%
In words.protocols.jabber.xmlstream in Twisted through 19.2.1, XMPP support did not verify certificates when used with TLS, allowing an attacker to MITM connections.
Action: Upgrade twisted to 19.7.0rc1 or later.
pip install twisted==19.7.0rc1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 19.7.0rc1 | - |
Fixed versions
| 19.7.0rc1 |
Sources
- osv: PYSEC-2019-129
- https://twistedmatrix.com/trac/ticket/9561
- https://github.com/twisted/twisted/pull/1147
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PLTZDMFBNFSJMBXYJNGJHENJA4H2TSMZ/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00013.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00028.html
- https://usn.ubuntu.com/4308-1/
- https://usn.ubuntu.com/4308-2/
- https://www.oracle.com/security-alerts/cpuapr2020.html
- https://github.com/advisories/GHSA-65rm-h285-5cc5
CVE-2019-12855 · published · modified · JSON