tocsin

PyPI/django CVE-2019-14235: high 7.5, EPSS 3.07%

An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. If passed certain inputs, django.utils.encoding.uri_to_iri could lead to significant memory usage

Action: Upgrade django to 1.11.23 or later.

pip install django==2.2.4
pip install django==1.11.23
pip install django==2.1.11

Affected

introducedfixedlast affected
1.111.11.23-
2.12.1.11-
2.22.2.4-

Fixed versions

2.2.41.11.232.1.11

Sources

CVE-2019-14235 · published · modified · JSON