PyPI/ironic-inspector CVE-2019-10141: unknown, EPSS 2.48%
A vulnerability was found in openstack-ironic-inspector all versions excluding 5.0.2, 6.0.3, 7.2.4, 8.0.3 and 8.2.1. A SQL-injection vulnerability was found in openstack-ironic-inspector's node_cache.
Action: Upgrade ironic-inspector to 5.0.2 or later.
pip install ironic-inspector==7.2.4pip install ironic-inspector==8.2.1pip install ironic-inspector==5.0.2pip install ironic-inspector==6.0.3pip install ironic-inspector==8.0.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 5.0.2 | - |
| 5.1.0 | 6.0.3 | - |
| 6.1.0 | 7.2.4 | - |
| 8.0.0 | 8.0.3 | - |
| 8.1.0 | 8.2.1 | - |
Fixed versions
| 7.2.4 | 8.2.1 | 5.0.2 | 6.0.3 | 8.0.3 |
Sources
- osv: PYSEC-2019-152
- https://docs.openstack.org/releasenotes/ironic-inspector/ocata.html#relnotes-5-0-2-7-origin-stable-ocata
- https://docs.openstack.org/releasenotes/ironic-inspector/stein.html#relnotes-8-2-1-stable-stein
- https://docs.openstack.org/releasenotes/ironic-inspector/queens.html#relnotes-7-2-4-stable-queens
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10141
- https://docs.openstack.org/releasenotes/ironic-inspector/rocky.html#relnotes-8-0-3-stable-rocky
- https://docs.openstack.org/releasenotes/ironic-inspector/pike.html#relnotes-6-0-3-4-stable-pike
- https://access.redhat.com/errata/RHSA-2019:2505
- https://github.com/advisories/GHSA-c7fc-cm7p-92r2
CVE-2019-10141 · published · modified · JSON