PyPI/aubio CVE-2018-19800: unknown, EPSS 2.23%
aubio v0.4.0 to v0.4.8 has a Buffer Overflow in new_aubio_tempo.
Action: Upgrade aubio to 0.4.9 or later.
pip install aubio==0.4.9Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.4.0 | 0.4.9 | - |
Fixed versions
| 0.4.9 |
Sources
- osv: PYSEC-2019-162
- https://github.com/aubio/aubio/blob/0.4.9/ChangeLog
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00063.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00067.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/IYIKPYXZIWYWWNNORSKWRCFFCP6AFMRZ/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OHIRMWW4JQ6UHJK4AVBJLFRLE2TPKC2W/
- https://github.com/advisories/GHSA-grmf-4fq6-2r79
CVE-2018-19800 · published · modified · JSON