PyPI/colander CVE-2017-18361: high 7.5, EPSS 2.07%
In Pylons Colander through 1.6, the URL validator allows an attacker to potentially cause an infinite loop thereby causing a denial of service via an unclosed parenthesis.
Action: Upgrade colander to 1.7.0 or later.
pip install colander==1.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.7.0 | - |
Fixed versions
| 1.7.0 |
Sources
- osv: PYSEC-2019-167
- nvd: CVE-2017-18361
- https://github.com/Pylons/colander/pull/323
- https://github.com/Pylons/colander/issues/290
- https://github.com/advisories/GHSA-rv95-4wxj-6fqq
CVE-2017-18361 · published · modified · JSON