tocsin

PyPI/apache-airflow CVE-2019-12417: unknown, EPSS 1.28%

A malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views. This also presented a Local File Disclosure vulnerability

Action: Upgrade apache-airflow to 1.10.6rc1 or later.

pip install apache-airflow==1.10.6rc1

Affected

introducedfixedlast affected
01.10.6rc1-

Fixed versions

1.10.6rc1

Sources

CVE-2019-12417 · published · modified · JSON