PyPI/pyboolector CVE-2019-7560: medium 5.5, EPSS 0.96%
In parser/btorsmt2.c in Boolector 3.0.0, opening a specially crafted input file leads to a use after free in get_failed_assumptions or btor_delete.
Action: Upgrade pyboolector to 3.1.0 or later.
pip install pyboolector==3.1.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.1.0 | - |
Fixed versions
| 3.1.0 |
Sources
- osv: PYSEC-2019-252
- https://github.com/Boolector/boolector/issues/29
- https://github.com/Boolector/boolector/issues/28
CVE-2019-7560 · published · modified · JSON