PyPI/ipa CVE-2019-14867: unknown, EPSS 7.41%
A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way the internal function ber_scanf() was used in some components
Action: Upgrade ipa to 4.6.7 or later.
pip install ipa==4.6.7pip install ipa==4.7.4pip install ipa==4.8.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.6.2 | 4.6.7 | - |
| 4.7.0 | 4.7.4 | - |
| 4.8.0 | 4.8.3 | - |
Fixed versions
| 4.6.7 | 4.7.4 | 4.8.3 |
Sources
- osv: PYSEC-2019-28
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14867
- https://www.freeipa.org/page/Releases/4.8.3
- https://www.freeipa.org/page/Releases/4.6.7
- https://www.freeipa.org/page/Releases/4.7.4
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WLFL5XDCJ3WT6JCLCQVKHZBLHGW7PW4T/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/67SEUWJAJ5RMH5K4Q6TS2I7HIMXUGNKF/
- https://access.redhat.com/errata/RHSA-2020:0378
- https://access.redhat.com/errata/RHBA-2019:4268
- https://github.com/advisories/GHSA-7hpj-hfcr-5qwm
CVE-2019-14867 · published · modified · JSON