PyPI/ansible CVE-2019-14846: high 7.8, EPSS 0.51%
In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin
Action: Upgrade ansible to 2.6.20 or later.
pip install ansible==2.6.20pip install ansible==2.7.14pip install ansible==2.8.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.6.20 | - |
| 2.7.0 | 2.7.14 | - |
| 2.8.0 | 2.8.6 | - |
Fixed versions
| 2.6.20 | 2.7.14 | 2.8.6 |
Sources
- osv: PYSEC-2019-4
- nvd: CVE-2019-14846
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14846
- https://github.com/ansible/ansible/pull/63366
- https://access.redhat.com/errata/RHSA-2019:3207
- https://access.redhat.com/errata/RHSA-2019:3201
- https://access.redhat.com/errata/RHSA-2019:3202
- https://access.redhat.com/errata/RHSA-2019:3203
- https://access.redhat.com/errata/RHSA-2020:0756
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://github.com/advisories/GHSA-pm48-cvv2-29q5
CVE-2019-14846 · published · modified · JSON