PyPI/tensorflow CVE-2020-15206: unknown, EPSS 0.96%
In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, changing the TensorFlow's `SavedModel` protocol buffer and altering the name of required keys results in segfaults and data corrupt
Action: Upgrade tensorflow to 1.15.4 or later.
pip install tensorflow==1.15.4pip install tensorflow==2.0.3pip install tensorflow==2.1.2pip install tensorflow==2.2.1pip install tensorflow==2.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.15.4 | - |
| 2.0.0 | 2.0.3 | - |
| 2.1.0 | 2.1.2 | - |
| 2.2.0 | 2.2.1 | - |
| 2.3.0 | 2.3.1 | - |
Fixed versions
| 1.15.4 | 2.0.3 | 2.1.2 | 2.2.1 | 2.3.1 |
Sources
- osv: PYSEC-2020-129
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-w5gh-2wr2-pm6g
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/commit/adf095206f25471e864a8e63a0f1caef53a0e3a6
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
CVE-2020-15206 · published · modified · JSON