tocsin

PyPI/uvicorn CVE-2020-7694: unknown, EPSS 1.36%

This affects all versions of package uvicorn. The request logger provided by the package is vulnerable to ASNI escape sequence injection. Whenever any HTTP request is received, the default behaviour o

Action: Upgrade uvicorn to 0.11.7 or later.

pip install uvicorn==0.11.7

Affected

introducedfixedlast affected
00.11.7-

Fixed versions

0.11.7

Sources

CVE-2020-7694 · published · modified · JSON