tocsin

PyPI/ecdsa CVE-2019-14859: unknown, EPSS 1.53%

A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted,

Action: Upgrade ecdsa to 0.13.3 or later.

pip install ecdsa==0.13.3

Affected

introducedfixedlast affected
00.13.3-

Fixed versions

0.13.3

Sources

CVE-2019-14859 · published · modified · JSON