PyPI/waitress CVE-2019-16792: unknown, EPSS 1.98%
Waitress through version 1.3.1 allows request smuggling by sending the Content-Length header twice. Waitress would header fold a double Content-Length header and due to being unable to cast the now co
Action: Upgrade waitress to 1.4.0 or later.
pip install waitress==1.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.0 | - |
Fixed versions
| 1.4.0 |
Sources
- osv: PYSEC-2020-178
- https://docs.pylonsproject.org/projects/waitress/en/latest/#security-fixes
- https://github.com/Pylons/waitress/commit/575994cd42e83fd772a5f7ec98b2c56751bd3f65
- https://github.com/Pylons/waitress/security/advisories/GHSA-4ppp-gpcr-7qf6
- https://github.com/advisories/GHSA-j7j6-7hfx-5522
CVE-2019-16792 · published · modified · JSON