tocsin

PyPI/asyncpg CVE-2020-17446: unknown, EPSS 2.42%

asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized poin

Action: Upgrade asyncpg to 0.21.0 or later.

pip install asyncpg==0.21.0

Affected

introducedfixedlast affected
00.21.0-

Fixed versions

0.21.0

Sources

CVE-2020-17446 · published · modified · JSON