PyPI/py-bcrypt CVE-2013-1895: high 7.5, EPSS 2.83%
The py-bcrypt module before 0.3 for Python does not properly handle concurrent memory access, which allows attackers to bypass authentication via multiple authentication requests, which trigger the pa
Action: Upgrade py-bcrypt to 0.3 or later.
pip install py-bcrypt==0.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.3 | - |
Fixed versions
| 0.3 |
Sources
- osv: PYSEC-2020-249
- nvd: CVE-2013-1895
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101382.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/83039
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101387.html
- http://www.openwall.com/lists/oss-security/2013/03/26/2
- http://www.securityfocus.com/bid/58702
- https://github.com/advisories/GHSA-r838-q6jp-58xx
CVE-2013-1895 · published · modified · JSON