tocsin

PyPI/aws-encryption-sdk CVE-2020-8897: unknown, EPSS 0.40%

A weak robustness vulnerability exists in the AWS Encryption SDKs for Java, Python, C and Javalcript prior to versions 2.0.0. Due to the non-committing property of AES-GCM (and other AEAD ciphers such

Action: Upgrade aws-encryption-sdk to 2.0.0 or later.

pip install aws-encryption-sdk==2.0.0

Affected

introducedfixedlast affected
02.0.0-

Fixed versions

2.0.0

Sources

CVE-2020-8897 · published · modified · JSON