PyPI/tensorflow-cpu CVE-2020-15193: unknown, EPSS 0.83%
In Tensorflow before versions 2.2.1 and 2.3.1, the implementation of `dlpack.to_dlpack` can be made to use uninitialized memory resulting in further memory corruption. This is because the pybind11 glu
Action: Upgrade tensorflow-cpu to 2.2.1 or later.
pip install tensorflow-cpu==2.2.1pip install tensorflow-cpu==2.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.1 | - |
| 2.3.0rc0 | 2.3.1 | - |
Fixed versions
| 2.2.1 | 2.3.1 |
Sources
- osv: PYSEC-2020-273
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rjjg-hgv6-h69v
- https://github.com/tensorflow/tensorflow/commit/22e07fb204386768e5bcbea563641ea11f96ceb8
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
CVE-2020-15193 · published · modified · JSON