PyPI/tensorflow-cpu CVE-2020-15203: unknown, EPSS 0.97%
In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, by controlling the `fill` argument of tf.strings.as_string, a malicious attacker is able to trigger a format string vulnerability d
Action: Upgrade tensorflow-cpu to 1.15.4 or later.
pip install tensorflow-cpu==1.15.4pip install tensorflow-cpu==2.0.3pip install tensorflow-cpu==2.1.2pip install tensorflow-cpu==2.2.1pip install tensorflow-cpu==2.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.15.4 | - |
| 2.0.0 | 2.0.3 | - |
| 2.1.0 | 2.1.2 | - |
| 2.2.0 | 2.2.1 | - |
| 2.3.0 | 2.3.1 | - |
Fixed versions
| 1.15.4 | 2.0.3 | 2.1.2 | 2.2.1 | 2.3.1 |
Sources
- osv: PYSEC-2020-283
- https://github.com/tensorflow/tensorflow/commit/33be22c65d86256e6826666662e40dbdfe70ee83
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xmq7-7fxm-rr79
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
CVE-2020-15203 · published · modified · JSON