PyPI/tensorflow-gpu CVE-2020-26270: unknown, EPSS 0.17%
In affected versions of TensorFlow running an LSTM/GRU model where the LSTM/GRU layer receives an input with zero-length results in a CHECK failure when using the CUDA backend. This can result in a qu
Action: Upgrade tensorflow-gpu to 1.15.5 or later.
pip install tensorflow-gpu==1.15.5pip install tensorflow-gpu==2.0.4pip install tensorflow-gpu==2.1.3pip install tensorflow-gpu==2.2.2pip install tensorflow-gpu==2.3.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.15.5 | - |
| 2.0.0 | 2.0.4 | - |
| 2.1.0 | 2.1.3 | - |
| 2.2.0 | 2.2.2 | - |
| 2.3.0 | 2.3.2 | - |
Fixed versions
| 1.15.5 | 2.0.4 | 2.1.3 | 2.2.2 | 2.3.2 |
Sources
- osv: PYSEC-2020-336
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-m648-33qf-v3gp
- https://github.com/tensorflow/tensorflow/commit/14755416e364f17fb1870882fa778c7fec7f16e3
CVE-2020-26270 · published · modified · JSON