tocsin

PyPI/pyspark CVE-2020-9480: unknown, EPSS 29.37%

In Apache Spark 2.4.5 and earlier, a standalone resource manager's master may be configured to require authentication (spark.authenticate) via a shared secret. When enabled, however, a specially-craft

Action: Upgrade pyspark to 2.4.6 or later.

pip install pyspark==2.4.6

Affected

introducedfixedlast affected
02.4.6-

Fixed versions

2.4.6

Sources

CVE-2020-9480 · published · modified · JSON