PyPI/django CVE-2021-35042: unknown, EPSS 44.37%
Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection if order_by is untrusted input from a client of a web application.
Action: Upgrade django to 3.1.13 or later.
pip install django==3.1.13pip install django==3.2.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.1 | 3.1.13 | - |
| 3.2 | 3.2.5 | - |
Fixed versions
| 3.1.13 | 3.2.5 |
Sources
- osv: PYSEC-2021-109
- https://docs.djangoproject.com/en/3.2/releases/security/
- https://www.openwall.com/lists/oss-security/2021/07/02/2
- https://groups.google.com/forum/#!forum/django-announce
- https://www.djangoproject.com/weblog/2021/jul/01/security-releases/
- https://github.com/advisories/GHSA-xpfp-f569-q3p2
CVE-2021-35042 · published · modified · JSON