PyPI/tensorflow CVE-2021-29560: unknown, EPSS 0.21%
TensorFlow is an end-to-end open source platform for machine learning. An attacker can cause a heap buffer overflow in `tf.raw_ops.RaggedTensorToTensor`. This is because the implementation(https://git
Action: Upgrade tensorflow to 2.2.0rc0 or later.
pip install tensorflow==2.2.0rc0pip install tensorflow==2.3.0rc0pip install tensorflow==2.3.4pip install tensorflow==2.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.0rc0 | - |
| 2.2.0 | 2.3.0rc0 | - |
| 2.3.0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
Fixed versions
| 2.2.0rc0 | 2.3.0rc0 | 2.3.4 | 2.4.3 |
Sources
- osv: PYSEC-2021-197
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-8gv3-57p6-g35r
- https://github.com/tensorflow/tensorflow/commit/a84358aa12f0b1518e606095ab9cfddbf597c121
CVE-2021-29560 · published · modified · JSON