PyPI/tensorflow CVE-2021-29590: unknown, EPSS 0.20%
TensorFlow is an end-to-end open source platform for machine learning. The implementations of the `Minimum` and `Maximum` TFLite operators can be used to read data outside of bounds of heap allocated
Action: Upgrade tensorflow to 2.1.4 or later.
pip install tensorflow==2.1.4pip install tensorflow==2.2.3pip install tensorflow==2.3.3pip install tensorflow==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: PYSEC-2021-227
- https://github.com/tensorflow/tensorflow/commit/953f28dca13c92839ba389c055587cfe6c723578
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-24x6-8c7m-hv3f
CVE-2021-29590 · published · modified · JSON