PyPI/apache-airflow CVE-2021-26697: unknown, EPSS 4.55%
The lineage endpoint of the deprecated Experimental API was not protected by authentication in Airflow 2.0.0. This allowed unauthenticated users to hit that endpoint. This is low-severity issue as the
Action: Upgrade apache-airflow to 2.0.1 or later.
pip install apache-airflow==2.0.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.0.1 | - |
Fixed versions
| 2.0.1 |
Sources
- osv: PYSEC-2021-3
- https://lists.apache.org/thread.html/re21fec81baea7a6d73b0b5d31efd07cc02c61f832e297f65bb19b519%40%3Cusers.airflow.apache.org%3E
- https://lists.apache.org/thread.html/r36111262a59219a3e2704c71e97cf84937dae5ba7a1da99499e5d8f9@%3Cannounce.apache.org%3E
- http://www.openwall.com/lists/oss-security/2021/02/17/2
- https://lists.apache.org/thread.html/re21fec81baea7a6d73b0b5d31efd07cc02c61f832e297f65bb19b519@%3Cdev.airflow.apache.org%3E
- https://lists.apache.org/thread.html/re21fec81baea7a6d73b0b5d31efd07cc02c61f832e297f65bb19b519@%3Cusers.airflow.apache.org%3E
- https://github.com/advisories/GHSA-fh37-cx83-q542
CVE-2021-26697 · published · modified · JSON