PyPI/tensorflow CVE-2021-37692: unknown, EPSS 0.17%
TensorFlow is an end-to-end open source platform for machine learning. In affected versions under certain conditions, Go code can trigger a segfault in string deallocation. For string tensors, `C.TF_T
Action: Upgrade tensorflow to 2.3.4 or later.
pip install tensorflow==2.3.4pip install tensorflow==2.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.3.0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
Fixed versions
| 2.3.4 | 2.4.3 |
Sources
- osv: PYSEC-2021-314
- https://github.com/tensorflow/tensorflow/pull/50508
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cmgw-8vpc-rc59
- https://github.com/tensorflow/tensorflow/commit/8721ba96e5760c229217b594f6d2ba332beedf22
CVE-2021-37692 · published · modified · JSON