PyPI/neutron CVE-2021-40797: unknown, EPSS 1.77%
An issue was discovered in the routes middleware in OpenStack Neutron before 16.4.1, 17.x before 17.2.1, and 18.x before 18.1.1. By making API requests involving nonexistent controllers, an authentica
Action: Upgrade neutron to 16.4.1 or later.
pip install neutron==16.4.1pip install neutron==17.2.1pip install neutron==18.1.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 16.4.1 | - |
| 17.0.0 | 17.2.1 | - |
| 18.0.0 | 18.1.1 | - |
Fixed versions
| 16.4.1 | 17.2.1 | 18.1.1 |
Sources
- osv: PYSEC-2021-329
- https://launchpad.net/bugs/1942179
- https://security.openstack.org/ossa/OSSA-2021-006.html
- http://www.openwall.com/lists/oss-security/2021/09/09/2
- https://github.com/advisories/GHSA-cpx3-696p-3cw9
CVE-2021-40797 · published · modified · JSON