PyPI/tensorflow CVE-2021-41197: unknown, EPSS 0.32%
TensorFlow is an open source platform for machine learning. In affected versions TensorFlow allows tensor to have a large number of dimensions and each dimension can be as large as desired. However, t
Action: Upgrade tensorflow to 2.4.4 or later.
pip install tensorflow==2.4.4pip install tensorflow==2.5.2pip install tensorflow==2.6.1pip install tensorflow==2.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
| 2.7.0rc0 | 2.7.0 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 | 2.7.0 |
Sources
- osv: PYSEC-2021-390
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-prcg-wp5q-rv7p
- https://github.com/tensorflow/tensorflow/commit/a871989d7b6c18cdebf2fb4f0e5c5b62fbc19edf
- https://github.com/tensorflow/tensorflow/commit/d81b1351da3e8c884ff836b64458d94e4a157c15
- https://github.com/tensorflow/tensorflow/issues/46890
- https://github.com/tensorflow/tensorflow/issues/51908
- https://github.com/tensorflow/tensorflow/commit/7c1692bd417eb4f9b33ead749a41166d6080af85
CVE-2021-41197 · published · modified · JSON