PyPI/tensorflow CVE-2021-41199: unknown, EPSS 0.24%
TensorFlow is an open source platform for machine learning. In affected versions if `tf.image.resize` is called with a large input argument then the TensorFlow process will crash due to a `CHECK`-fail
Action: Upgrade tensorflow to 2.4.4 or later.
pip install tensorflow==2.4.4pip install tensorflow==2.5.2pip install tensorflow==2.6.1pip install tensorflow==2.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
| 2.7.0rc0 | 2.7.0 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 | 2.7.0 |
Sources
- osv: PYSEC-2021-392
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-5hx2-qx8j-qjqm
- https://github.com/tensorflow/tensorflow/issues/46914
- https://github.com/tensorflow/tensorflow/commit/e5272d4204ff5b46136a1ef1204fc00597e21837
CVE-2021-41199 · published · modified · JSON